shared phobos library doesn't work on all linux distributions

The problem is that the currently distributed libphobos2.so is linked against a GnuTLS version of libcurl (libcurl-gnutls.so.4) but Fedora only ships with an OpenSSL version of that library. ---- ldd -r /usr/lib64/libphobos2.so ---- ldd: warning: you do not have execution permission for `/usr/lib64/libphobos2.so' linux-vdso.so.1 => (0x00007fffbcd30000) libcurl-gnutls.so.4 => not found libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f6cfdf75000) libm.so.6 => /lib64/libm.so.6 (0x00007f6cfdc74000) librt.so.1 => /lib64/librt.so.1 (0x00007f6cfda6c000) libc.so.6 => /lib64/libc.so.6 (0x00007f6cfd6b3000) /lib64/ld-linux-x86-64.so.2 (0x0000003dc8c00000) undefined symbol: _Dmain (/usr/lib64/libphobos2.so) undefined symbol: curl_easy_setopt, version CURL_GNUTLS_3 (/usr/lib64/libphobos2.so) undefined symbol: curl_slist_append, version CURL_GNUTLS_3 (/usr/lib64/libphobos2.so) undefined symbol: curl_slist_free_all, version CURL_GNUTLS_3 (/usr/lib64/libphobos2.so) undefined symbol: curl_global_cleanup, version CURL_GNUTLS_3 (/usr/lib64/libphobos2.so) undefined symbol: curl_easy_strerror, version CURL_GNUTLS_3 (/usr/lib64/libphobos2.so) undefined symbol: curl_easy_init, version CURL_GNUTLS_3 (/usr/lib64/libphobos2.so) undefined symbol: curl_easy_cleanup, version CURL_GNUTLS_3 (/usr/lib64/libphobos2.so) undefined symbol: curl_easy_duphandle, version CURL_GNUTLS_3 (/usr/lib64/libphobos2.so) undefined symbol: curl_easy_perform, version CURL_GNUTLS_3 (/usr/lib64/libphobos2.so) undefined symbol: curl_easy_pause, version CURL_GNUTLS_3 (/usr/lib64/libphobos2.so) undefined symbol: curl_global_init, version CURL_GNUTLS_3 (/usr/lib64/libphobos2.so) ----